System Requirements

System Requirements

SYSTEM REQUIREMENTS

For optimal performance while using Edusmart, we recommend upgrading to the latest versions of the

supported browsers and additional requirements below.

Supported Browsers:

  • Google Chrome (latest version) Download the latest version
  • Firefox (latest version) Download the latest version
  • Safari 10 and 11 Download the latest version

Additional Requirements:

  • Javascript enabled. (How to enable?) 
  • PDF viewer application - Adobe Reader 10 or greater
  • Flash 9+ (required for Spanish content only)
  • Cookies enabledWebsites often store cookies and other data as you browse online. This data may include information that you have provided in the past, such as your name, email address, and preferences. This data helps websites such as EduSmart identify you when you return to the site, and helps the site remember the user's preferences or registration details for a future visit. On EduSmart, enabling cookies in your browser can help prevent login issues to lms.edusmart.com.

Firewall Configurations: Please remove any viewing restrictions and allow access to the following url's : 

  • *.edusmart.com
  • *us-east-1.elb.amazonaws.com
  • *djhnsne82qiu.cloudfront.net.

Check your firewall settings to allow .MP4 video format.

Ensure outgoing traffic rules for ports 80, 443

  • Ports 80 and 443 are used for standard Edusmart web traffic. (http and https).

Would you like a free trial of Edusmart?

Questions? Call Us

800-318-9172

Contact Us